Comments for Aquabot pool rover control box lights flashing won't come on or move.

Average Rating starstarstarstarstar

Click here to add your own comments

Sep 22, 2017
Rating
starstarstar
Blinking LEDs
by: BudBuono

This device is a nightmare inflicted on the American pool owners by incompetent Chinese manufactures. My Aquabot is barely 4 months old and it has already F'd Up.
God help us all...pissed off in Richmond, VA

Jun 15, 2017
Rating
starstarstarstarstar
Aquabot control unit not working led lightsflash
by: Radonic

Had this aqua bot for a year..my control box led lights flashing..bot not working. Timer is fine, i am an electrician..I know when i have power and good timer. This is simply a product malfunction. Seems like a common problem with other buyers, what do we do?

May 17, 2017
Rating
starstarstarstarstar
Timer replacement
by: ADMIN

The timer can be purchased at
http://www.aquaqualitypools.com/parts_list_aqua_products_pool_rover_plus.htm

I believe the timer is secured with 2 screws. Pull the timer away from the case. The wires must be cut and reconnected with insulated butt connectors.
Moderate handyman skill required

May 17, 2017
Rating
starstarstarstarstar
Timer
by: Anonymous

If in fact I need a timer, where would I purchase one? Is this something I can replace myself?

May 16, 2017
Rating
starstarstarstarstar
the Timer
by: ADMIN

Chances are...you need a new timer...the dohickey with the dial or run button

May 16, 2017
Rating
starstarstarstarstar
Aquabot plus
by: Anonymous

I am having a similar issue. Robot turns on, runs for 15 seconds, then shuts off and the lights that indicate large/small pool begin to start and robot shuts off. Please help!

Jul 02, 2016
Rating
starstarstarstarstar
Timer
by: ADMIN

If you don't have power at the outlet (where the robot plugs into the box) Chances are really really good you need a new timer.

Jul 02, 2016
Rating
starstarstarstarstar
Flashing lights
by: Bill G

Unit turns on, lights for choosing small or large pool are flashing. That's all it does. Unit doesn't move. Unit is an XLS only 2 years old.

Aug 07, 2015
Rating
starstarstarstarstar
Flashing lights
by: Anonymous

I'm having a similar problem as well , last week the fuse blew in my power supply , I replaced the fuse and power was restored . Now when I turn my power supply on and plug in my robot and hit the program button the power goes out but automatically comms back on . No movement to the robot ? Please help !!!!

Jul 22, 2015
Rating
starstarstarstarstar
Flashing LEDs
by: Anonymous

Hi,

Im having the same issue. My aquabot will run fine for 10-15 seconds then the LEDs start flashing and the aquabot stops working. It seems it just needs to be reset but I have no idea how you do this with no visible reset options. Please help!

Jun 23, 2015
Rating
starstarstarstarstar
Results?
by: Anonymous

I have the same problem. Did you ever find a solution?

Jun 14, 2015
Rating
starstarstarstarstar
Powr cable short?
by: ADMIN

I am guessing the power cable may have a short but can't say for sure. Your best option is contacting Aqua Quality Pools and Spas.

Click here to add your own comments

Join in and write your own page! It's easy to do. How? Simply click here to return to Repair stories.

Return to Aquabot pool rover control box lights flashing won't come on or move. .