Aquabot Troubleshooting

TOOL for Aquabot troubleshooting: Multimeter(tutorial opens new window) , an electrical testing device that may be purchased for about 25 dollars and is invaluable around the home.

With the exception of learning several easy diagnostic tests performed with a multimeter, Aquabot troubleshooting does not require any special mechanical skill.

Custom Search







My Pool Cleaner Is Stuck On The Main Drain.

Wet Transformer, Wet Power Supply. How to fix it

AQUABOT WON'T CLIMB, PUMP and MOTOR WORKING

Your robot climbs because pump suction holds it to the wall while the drive system propels it up the wall. If wheels and treads are moving smoothly with NO wheel hesitations but robot won't climb...

A. CHECK THE IMPELLER! Remove the cap on top of the robot and remove all hair or other obstructions. If the pump can't pull enough water, your robot won't climb to the waterline.

B. Replace the rubber treads

C. Clean the Bag

If the wheels are moving intermittently, or in a halting manner, then change the drive belts , all 4 bushings on the drive side...that's one each for the wheels and 2 for the drive gear that turns the belts and change the stepped rollers. Thats 4 bushings, 2 stepped rollers. 2 belts.

Less likely but possible is a worn drive gear. Scroll down to ROBOT NOT MOVING for more information'

Look at the wheel axles that sit in the bushings. If they look like the wheel on the right (below), replace the wheel.


Aquabot Wheel

AQUABOT IS DEAD IN THE WATER

If BOTH pump and motor are not working, (Pool cleaner is not pumping water or moving) then the problem is most likely electrical Troubleshoot the power supply

1) Reset your GFI outlet and test the outlet for power with a multimeter on the Vac 200 setting or plug a small appliance into the outlet.

Photos of Internal timer transformer and bypass

Photos of external timer transformer and bypass

2) Press the reset (if equipped) on the Power Transformer and check the fuse. Some transformers have a reset switch that must be pushed every time the machine is started.

3) Check for voltage at the Power Transformer with a multimeter set to Vac 200. Replace the transformer if no voltage is detected.

Aquabot Troubleshooting-The transformer: case open and UNPLUGGED. I say again, DO NOT PLUG IN the transformer with the case removed. NEVER do a continuity check with the power on.

a)Perform a continuity check on the reset button by holding a probe on each terminal and holding in the reset. Continuity should be there when the button is pressed. If not, replace the reset switch

b)Perform a continuity check on the fuse holder.

c)Perform a continuity check of the on/off switch. If the transformer is OK, on to step 4.

voltage testing aquabot transformer

Voltage testing a two wire Aquabot Turbo transformer.

The above photo is a 6 wire Transformer for Turbo Plus w/remote voltage test.

4) With the robot submerged, wiggle the cord between the handle and the motor. If the robot momentarily comes to life, replace or repair the cord. Check the cord plug end for broken contacts. Replace the plug if needed. May be checked with a continuity test on the multimeter.

5) BE SURE THE PLUG IS IN ALL THE WAY!



PUMP IS WORKING, POOL CLEANER WILL NOT MOVE.

1) Look for a broken or loose slipping drive belt. Be certain the belts are routed properly over the stepped rollers.

2) Be sure the sideplate bushing that holds the drive shaft is intact.

3) The drive shaft has a plastic coated end that inserts into the bushing. If the plastic is gone, replace the drive shaft assembly


Aquabot Repair

2) With the robot submerged, check to see if the drive gear is turning. If YES, replace the belts. If NO, check that the pin pressed into the axle to turn the drive gear is still there. SEE BELOW PHOTOS.

Aquabot Motor Repair



Aquabot Motor

As a LAST resort do number 3

3) Remove the robot from the water and lay upside down. Turn on the robot for a maximum of ONE minute. Turn a wheel a little in each direction to unbind the motor.

If this does not work, replace the motor.

AQUABOT WILL NOT REVERSE

Assuming belts are good and installed correctly and a wheel is not falling out of the sideplate, you need a new motor.

ROBOT MOVES, WATER PUMP IS NOT WORKING.

1) Check impeller for debris such as hair, weeds or leaves.

2) Operate the robot without the filter bag, if the pump works ok, get a new bag or clean the one you have.

3) Troubleshoot your cable. Check for broken wires between the pump and motor. Use a continuity test out of water. Disconnect the pump to check the wires. If a broken wire is found, fix it. Otherwise,

replace the pump.

AQUABOT STOPS RUNNING AFTER SHORT TIME It may run for a short period after turning power off and on.

The most likely problem is the timer on or in the power supply.

To check, when the robot stops, unplug the robot from the transformer and check for voltage at the power transformer outlet. This is easy to do with a multimeter.

The timer may be replaced for about $50 or bypassed at zero cost. Bypassing the timer means the robot runs for as long as the power is turned on.

MOST COMMON AQUABOT TROUBLESHOOTING PROBLEMS

1) Power cord has a broken wire between motor and handle clamp.

2) Broken or loose drive belt(s). Worn wheel, stepped rollers and drive gear bushings will cause a loose belt. Always replace bushings and rollers with the belts.

3) Plug end is worn or broken.

4) On older Aquabots, water in the terminal well corrodes the wires on both the cord and pump causing breakage.

5) Bad timer in power supply causing no or erratic operation.

NEVER buy a new pump BEFORE inspecting the wire ends on the old pump for breakage

Test all wires with a continuity test. It is easy to do and must be done with the robot and transformer UNplugged.

Robot Eats The CableI frequently hear "my robot always eats the power cord". Keep the cord out of the robots mouth, tangle free and untwisted. Coil the wire from the robot to the plug.

Richard from Aquaquality Pools and Spas, Inc has this tip he credits to Aqua Products. Wrap a foam "noodle" around the cord to keep it afloat. Merely slice open the noodle and insert the cable.

Just an aside, I use the TOMCAT cables Richard makes and they always re-coil nicely and never been eaten.

Try changing the handle position mid-cycle to reverse the twisting caused by the robots natural movement. For more Aquabot troubleshooting ideas, search this site for a specific problem.

Aquabot troubleshooting is easiest with a cheap mutimeter.



Did you find what you were looking for on this Aquabot Troubleshooting page? If not, search the site for more information.

Back to HOME from Aquabot Troubleshooting