Dolphin 4 - Algae Coming Out the Top

by Eric
(Oklahoma City, OK)

I bought a used Dolphin 4 and it works well. The problem is that even though it is sucking up the debris and dirt, it seems to let the algae through. As it moves around, you can see the green exhaust coming out of the top. I keep seeing a response about a torn bag, but there are no bags on this robot. Any idea what I need to tweak?

Comments for Dolphin 4 - Algae Coming Out the Top

Average Rating starstarstarstarstar

Click here to add your own comments

Apr 30, 2017
Rating
starstarstarstarstar
Sounds OK to me
by: Curtis

Algae can be very tiny. Run your filter until its gone. So important to prevent the algae bloom with adequate chlorine and balanced water.
If you use a mesh cover, open the pool sooner.

Here is a good page to visit.

http://www.i-love-my-aquabot-automatic-pool-cleaner.com/swimming-pool-chemicals.html

Apr 28, 2017
Rating
starstarstarstarstar
Filters
by: Eric

I have the four filters (two for large debris) and two for finer debris. I shocked the pool and the dead algae fell to the bottom of the pool. So when the Dolphin ran, it sucked it up, but obviously it is getting past the filters. The sand and dirt gets stopped. So, I guess I might not be doing anything wrong after all?

Apr 28, 2017
Rating
starstarstarstarstar
No Bag?
by: Curtis

You have a cartridge filter? If so, the filtering efficiency is less than a bag. Algae can be microscopic.
The bigger problem is why you have algae in the first place. If your chlorine level is normal then check the cyanuric acid level (stabilizer) for every 10 parts cyanuric acid you need 1 part chlorine or the chlorine wont kill anything.

Click here to add your own comments

Join in and write your own page! It's easy to do. How? Simply click here to return to Dolphin Maytronics Repair Comments.