Aquabot Repair Stories

Please Share your Good and Bad Repair Stories

Do you have a story about robotic pool cleaner repair? ANY model or make. If you own one, you can write one!
Submissions are found at the bottom of this page.

[ ? ]

Upload 1-4 Pictures or Graphics (optional)[ ? ]

 

Click here to upload more images (optional)

Author Information (optional)

To receive credit as the author, enter your information below.

(first or full name)

(e.g., City, State, Country)

Submit Your Contribution

 submission guidelines.


(You can preview and edit on the next page)

What Other Visitors Have Said

Click below to see contributions from other visitors to this page...

Aquabot Pool Rover Power supply or Pump Motor? 
Looking for help? I have an old Pool Rover plus for above ground pools that had worked great for years. It has stopped working. I need to know which …

Aquabot repair ? no help on-line 
I have an very old Aqubot pool rover for above ground model E1590, ser# 4700099.  That had worked great for years.  It has stopped moving as the pump motor …

Aquabot Turbo Solo blowing fuses but passes continuity. 
Hello, I have a 2008 Aquabot Turbo Solo that just started blowing fuses. Here is what I have found out so far. Any guidance on the best next steps …

Repair Viva AS06080SP Pump 
In a related post (Aquabot Bravo – Pandora Smart) I promised to post details of the repair of the suction pump on my Aquabot Viva. The part number of the …

Aquabot Extreme no longer follows cleaning pattern 
My Aquabot Extreme is 4 years old. It no longer follows the cleaning pattern it used to. Basically just goes back and forth without adjusting direction. …

aquabot pumps but wont move then shuts off 
My aquabot only gets used from mid May, June, July, and goes to bed mid August. For a robot that only gets used 3 months a year it should not need so …

Aquabot Hesitates  
My aquabot classic hesitates every foot or so. Works ok except that every foot the aquabot pauses for a moment.. Let it run to clean entire pool hesitates …

Aquabot junior issues 
hey! my aquabot junior is about 3 yrs old, it started moving kinda jerky...12" then stop 12' then stop then reverse and do the same. it cleaned but didn't …

Eco-Jet Turbo not working 
Attempted to use our 2011 Eco-Jet Turbo last week. Though it started right up, it went for only 1-2 minutes before it stopped. The transformer is working …

2011 and newer aquabot drive motor repair 
I have a 2012 aquabot that has a dead drive motor so I removed the drive motor assembly from the robot and disassembled it. When I removed the brushless …

Aquabot Classic drive motor question 
I'm new here so forgive me if this is not the right place to post a question to the group but it is the only I have found. I am learning to repair an …

Rover 
I left my Rover in the rain and now the transmitter will not come on I took it to Islander pools and they told me to buy a new transmitter for $247.00!! …

No Output From Power Supply 
My four year old Aquabot Turbo power supply has failed. All components of the supply are good except the transformer. Removed the transformer. With a temporary …

Pump propeller spins wrong direction 
I own a CTX Typhoon pool cleaner and the pump I believe is the same that is used in some aquabot models (P/N: AS00035R). The isse that I have is that the …

Aquabot Bravo no longer working - power supply issue? 
Hi all, My six year old Aquabot Bravo has stopped working. When I press the button on the power supply, it kicks into gear like all is well, but then …

aquabot fury doesnt start 
I press the power button and the light turns on, the aquabot motor doesnt start and then aftera few seconds the light flickers then turns off

Aquabot Turbo T2 moves then stops 
I have a Turbo T2 which moves slightly and then stops. The pump comes on and I've replaced the belts and the rollers but that didn't seem to do the trick. …

Aquabot Junior Goes In One Direction 
Only goes one direction. Will not reverse direction. Any help is appreciated. New unit. Hoping for a easy fix don't need the hassle of returning unit.

Pump motor Capacitor SURPRISE rectifier 
I opened my failed Turbo T2 to install the new capacitors, removed the spongy resin by heating with a heat gun and crumbling/picking it away with small …

not lifting loose dust 
My Aqubot junior collects leaves and debris but wont lift dust. I know the dust is loose because it sweeps easily. I clean the bag religiously after each …

AQUABOT® TURBO T2 Pool Cleaner Drive Motor, Part # A8541  
I am looking for instructions to disassemble the blue drive motor. I have voltage going to the motor yet the motor or pump will not come on. I know how …

Aquabot Bravo 
Aquabot ( idealbot) Bravo S/N 24087541. Purchased 1st June 2012 Hi, So I replaced my Aquabot Bravo Drive belts, for the second time. The first time …

NEED INFO ON AQUABOT MOTORS (PUMP AND DRIVE!) 
I am trying to rectify my broken aquabot with another broken aquabot. Both are T2 models, but it seems I am getting 24v DC to the pump motor which …

Not cleaning bottom of the pool 
My aquabot junior used to do real well. But now it doesn't seem to clean the smallest of dirt spots. Did we do something wrong? how can I fix this. We …

Click here to write your own.

AQUABOT TURBO T2 
BY PASSED TIMER MODULE, PLUG IN POWER SUPPLY, IT BLOWS FUSE INSTANTLY. TESTED BOTH WINDINGS, HAVE CONTINUITY. COULD YOU GIVE ME SOME ADVICE ON WHAT MAY …

Aquabot pool rover control box lights flashing won't come on or move.  
We have had the pool rover for two seasons. Put in pool yesterday and it worked for a few minutes then the lights on the control box started flashing and …

Aqua bot junior will not come up and clean shallow end of pool 
i own an Aqua bot jr. i have owned it for 2 years and it is great. However it will not come up to the shallow end of my pool it cleans the deep end great. …

Runs for less than 1 minute 
When I turn on my aquabot the vacuum motor runs for a few seconds then stops and then the drive motor runs forward for 10 seconds then reverses for 10 …

Dolphin DX4 Robotic Pool Cleaner Power Supply  
My DX4 power supply has no voltage output. Is there a wiring schematic? It worked 1st time this season, after cleaning, it stopped. I have the blue power …

Aquabot S2-40 not working 
Have had the S2-40 for two years. Use once a week during the summer months. Store inside during the winter. Went to put in my pool. The base unit appears …

Power Supply 
I have worked on power before and on bigger projects so I am fully aware death can occur while working on this transformer. Now that this is out of the …

Blue Diamond RC 4 pin plug wiring info 
I am trying to revive a dead pool cleaner with no any information and reverse engineering almost everything. There are many people tried to restore this …

Pool Rover S240 won't go in reverse 
Bought my Pool Rover S2-40 last year and it worked great all season. Near the end of the year, the cord got majorly tangled and ended up breaking the …

Ajet Power Supply 
My power supply for my Ajet S2-40 has stopped working. the voltage when you first turn it on is 109 then decreases until it stops and the 2 pool indicator …

Question about Turbo t4rc pump motor replqcement 
I cleaned impeller and pump motor works for few minutes then quits on occasion or just does not work. Is pump motor replacement (its 7-8 years old) likely …

where is the problem 
My aquabot stopped working. The impeller was first spinning slowly now not at all. Transformer and cable ok. Motor gets warm, almost hot to the touch. …

Replaced the 4 capacitors from the Motor 
..but do not know what should I use to pot/encapsulate them. Epoxy/Silicone? ADMIN REPLY: Epoxy. Marine Epoxy if you have some otherwise Epoxy.

Disassembling a different style (Merlin 8571) Aquabot motor 
So I had already used the instructions here to disassemble and repair the motor in my Aquabot classic. However I found that I needed to take apart and …

Aquabot Bravo - Pandora Smart 
I have a Pandora Smart Pool robot that has now stopped working. If I press the green button the power supply it immediately switches off within a second. …

How to detach motor assembly for Aquabot Turbo T-Jet? 
I'm having a hard time removing the Pump Motor Housing (Part#A6005-03, DIA #60) from the Plastic Jet Valve Assembly - the blue plastic assembly on top …

Aquabot Turbo Jet stops working when submerged 
My Aquabot is about 4 years old. It comes on just fine and the motor runs outside and when it just enters the pool, and the transformer cycles normally. …

Aquabot S2-40 
I believe that I have a timer issue in by Aquabot Does anyone know where I can find the electrical schematics for an Aquabot S2-40? This is my second …

Aquabot Bravo propeller not moving 
I have an Aquabot Bravo and it seems to be scurring along just fine, but its not moving any water. I checked the propeller and its not moving, the motor …

Drive motor works intermittently 
I have the aquabot turbo, its about 3 yrs old. When I turn it on, everything functions, but within 5 minutes the drive motor will stop working while the …

Drive Motor Oil Leaked out 
Hi guys, I hope you could help me to save some $400 as I really don't want to replace the whole motor. The drive motor's oil leaked out to the pool. Then, …

Pump not sucking in water but moves 
I ordered this 3 years ago.. it worked wonderfully but now it stopped. If I lift it 1/2 way it moves but it does not suck water or water shoots up like …

Request for information re: Drive Motor PCBand CAP values 
I have searched the site (great site BTW) looking for information about the DRIVE MOTOR PCB. I have two Aquabot Turbos that stopped reliably reversing …

Tangled cord 
My less than a year old turbo t 4rc started tangling its power cord. Unit cleans well except that ultimately the wire becomes so tangled it stops the …

Turbo T-Jet motor repair story, info, - and thanks 
Having read of similar issues and the various things people here had done to address them, I was able to repair my Turbo T-Jet. This is my 3rd Aquabot …

Click here to write your own.

Aquabot Pool Demon Still Blowing Fuse After Changing To A New Power Cord 
I had bought back-up parts for my Pool Demon Last Year. So when I noticed today the fuse had blown, I disconnected the cord from the motor and checked …

Don't Get an Aquabot if You MUST have the Newest Toy! 
I am always a sucker for having to have the newest coolest stuff. Hence 4 years ago my purchase of my Aquabot VIVA was a no brainer remote control and …

Aquabot won't start 
I have an Aquabot Turbo. It stopped working recently. I opened it up. When I test the motor (outside), it runs. But, it seems to produce a grinding noise …

Broken-off boss for motor terminal well cover plate 
I replaced my pump motor. When reinstalling the j-box cover plate (located on the bottom of the traction motor) the boss that accepts the screw that secures …

aquabot blows fuses - need help finding short 
3 year old aquabot blows fuses after 2 secs of powering on. Transformer disconnected from bot does not and voltmeter at output reads 38ish. So i think …

Aquabot Power Box Getting Wet from Rain 
Hi, I just purchased the AquaBot Turbo. Can the power supply box stay out there in the rain or should i take it in on days i know its going to rain? …

Aquabot Turbo (2006) won't reliably reverse 
My 2006 Aquabot Turbo recently wrapped its cord into the brushes. After clearing, the robot will not reverse. However, it does start out correctly, climbs …

Aquabot Turbo running over the wire 
Hello My 3 yr old Aquabot keeps running over its own wire when climbing the wall. Has anyone had this problem and if so what is the solution. What good …

Aquabot T-4 Blows Fuse's 
I have a aquabot turbo t4 that keeps blowing fuse's.I have turned on my transformer without the robot being hooked up and the fuse will not blow.I was …

Looking for old electric cords 
Hi, I am looking for old (any age) Aquabot electric cords (the really long ones) from which I remove the exterior rubber layer and re-use for lighting …

Pool cleaner drives, pump works, but seems like it is wrong direction... 
It just stopped working correctly. When I lifted it out, it seems the pump is sucking from the top and blowing out the bottom, causing everything in its …

Aquabot - Strange behaviour 
Hi and thanks for this forum. My old Aquabot (2007) has the strange following behaviours : 1. When I submerge my robot, the pump works for 2 or 3 seconds …

What voltage does pump motor run on? 
My pump stopped working. When I first checked it it would spin if I moved it with my finger, so I ordered the capacitors. Installed 1st set and it wouldn't …

Aquabot fuse type 
i am not sure what size fuse i know its a 250v but what amp

Aquabot stopping and reversing when it's not supposed to. 
Had my T2 for a little over a year. Already had to have the suction motor and drive motor replaced. Ever since it was fixed (by a certified repair center), …

Aquabot Pool Rover and Turbo T-Jet Motor Removal 
Remove the bottom plate. Remove the debris shield. There may be zip ties that need to be cut. Inside the robot, at the top on the Jet-Valve assembly, …

Aquabot Supreme with drive/pump motor issues 
Bought my Aquabot Supreme in 2010 and she worked great for almost a year. About three months ago I noticed the machine wasn't following it's normal lap …

Aquabot Storm doesn't move 
Have an aquabot storm and I love using it. This year we took it out of shed to do the opening cleaning. The unit turns on, bubbles come out, and it move …

Aquabot spins in circles 
My aquabot T4 just sits and spins. remote does nothing to help. motors are spinning in opposite directions. It lunges forward about 2-3 inches then stops …

Aquabot Pump Motor Capacitor's 
Ok....i replaced the caps in the motor and it still will not work ... i can push the prop with my finger and it will start working and then when i put …

Aquabot T4RC, tracks drive in opposite directions 
My Aquabot T4RC came with my home. After about a month, when you turn it on, it goes forward about 4 inches and stops and then spins in circles. Not 5 …

Aquabot T4 RC Pump Motor Repair 
I am employed as a supervisor / senior repair technician for all things "aquatic" at a very large resort and casino. T4RC units were purchased by the resort …

T4 Turbo with wireless remote pump jammed 
I have a T4 with wireless remote and found a piece of plastic which had jammed in the impeller. After freeing the impeller and restarting the unit the …

Aquabot Turbo T seems to have lost some power 
I have an aquabot turbo t and today I put it in the pool and it doesn't seem like it is hugging the floor of the pool well and when it tries to climb the …

Aquabot Transformer 
I am currently on my second Aquabot. The newest is 3 yrs old and has needed the usual new drive belts and exhaust propeller cleaning that I have no problem …

Click here to write your own.

Aquabot Turbo Pump Not Working 
I have an older turbo with a wired remote. It has quit working and I find the pump motor does not turn. Is there any trouble shooting tips? I have a 4 …

Aquabot Capacitor Replacement for Motor 
Aquabot Pump Motor Capacitor Repair by John LoGuirato (Holbrook, NY USA) Could not add picture to John page so just doing my own page to add picture …

Aquabot Drive motor will not work but jet pump still functions 
Can i get a drive motor for the aquabot that is under $400, the drive motor circuit board is corroded and looks like it needs to be replaced. how does …

Aquabot Turbo T Water Pump Pulses on-off-on-off 
I have a Turbo T which is 3 years old. The water pump starts up for about 20 seconds then continuously alternates from on to off to on to off to .... in …

My aquabot goes in circles 
I have a regular aquabot, and checked the electric with the meter as you instructed. I changed my drive belts pursuant to your website, the aquabot …

AquabotMoves Then Stops 
My aquabot is a year old, i live in the north east and only use it 3 months a year. When i put it in the water, it starts to move, and then stops. I unscrewed …

Aquabot Pool Demon Stops After 1 Hour.  
(this email series descreibes a problwm and subsequent fix) original messgage: I bought my Aquabot pool demon with my pool pkg 5 years ago. it worked …

Saved from being ripped off 
I called Aquaquality on Post ave in Westbury today on 7/17/10 to find out if they repaired Hayward pool pumps. The young girl I spoke to told me that they …

Aquabot climbs only upper half wall 
My aquabot is starting by climbing vertically the walls ,get to the limit of water and then go down one foot and climbs back to the edge again. Repeat. …

Fuse problem 
I have an older aquabot. How old, not sure...as it came with the pool when we bought house, but I'd bet it's at least 7 years old. Anyhow, it worked …

Aquabot Tempo Motor 
Hello, I have an urgent problem to solve. I would like to buy a Portescap type stepper motor to replace it for my Aquabot Tempo drive motor. Can I buy …

Spending to much time on walls 
Our pool is small 24'x12'x7'deep, the aquabot spends to much time cleaning the walls of the pool. I am finding that the ink on the vinyl wall is coming …

Aquabot Pump Motor Capacitor Repair 
I have repaired (2) pump motors now, instead of purchasing them for the outrageous $$$ that they go for new. First my own about 6 years ago by purchasing …

Aquabot Turbo T4RC 
Just placed Aquabot Turbo T4RC in pool, everything is working 'EXCEPT IT CIRCLES ONLY!!!' The pool if FULL of fishing worms from heavy rains & need to …

metal frame for debris bag corroated ,replacement $70 !!! 
poor design and choice of materials,shoud be stainless steel,must replace entire assembly,frame only not available.

Nettie's Aquabot Turbo Repair Tips 
I probably am on the last leg of repairing my Aquabot Turbo. It is getting old and brittle. I have replaced a lot of parts on this critter. I am a 73 year …

Aquabot No Suction and Not Climbing Wall 
I own an Aquabot and the other day I discovered it was not climbing the walls and not sucking any dirt. I pulled it out off the water and checked of any …

Aquabot Bravo 2003 power supply stops after 30 seconds 
Hello, I have a failure with a pool robot Aqua Smart System, bought in France (I'm French, living in France). This robot is also known as Aquabot Bravo …

Aquabot Turbo - Remote Not Working 
The remote used to work on my Aquabot Turbo, activating pistons on either side to make the robot turn. Recently, the remote does not cause the pistons …

Need schematic for Aquabot power supply remote control equiped unit  
Someone cut up the wiring on this power supply, which is a 4 pin unit with remote control. Basically, the power supply has been reduced to a pile of components, …

aquabot runs and works well for 5 minutes at a time 
Loved it but now it only works for 5 minutes at a time before shutting off? Three years old. REPLY: What is the model?

AQUABOT T2 STOPS AT RANDOM TIMES 
My aquabot T2 turbo will randomly stop (with pump still working). Usually just have to unplug it and it will start again. I think it may also be a touch …

Motor Shaft Pin Removal 
This is a series of e-mails to remove and replace a broken drive shaft pin. Original Question I have an older Aquabot turbo - it looks like the …

Aquabot is not moving or pumping 
I recently stuck the lil fella in the pool and he did not do anything. The light on the power supply went on and the power supply has approx. 33 volts …

Aquabot Slow/Not Moving Then Not Fully Reversing 
My Aquabot had started to show signs of not being able to propel itself the last time I used it, so this year when I tried to use it and it didn't move, …

Click here to write your own.

Aquabot blowing fuses 
I have a Two and half year old Aquabot. It stop working and I found that the fuse in the transformer had blown. Replaced the fuse with a 2.5 slow blow …

my aquabot just stopped running 
curt, my Aquabot would not run when i turned it on, then it started to run, then it stopped etc. I'd shake it & it would run for awhile, then both the …

Aquabot Bravo Loose Handle 
The click on part (yellow)of the handle inside the robot is broken on one side and makes the handle loose. How can I buy and easily replace that part …

Aquabot will not reverse 
Aquabot will not reverse REPLY: David, a fix is discussed on this page http://www.i-love-my-aquabot-automatic-pool-cleaner.com/fix-for-aquabot-motor-not-reversing.h …

Power supply output = Fuse blown and 3 wire plug 
I need to know what is the output of the power supply (at the three wire outlet)? I have about a 10 year old Aquabot Turbo. The power supply has flip …

Aquabot not pumping, motor replaced, Still not pumping. 
My Aquabot Turbo isn't pumping, but moves fine. I checked the wires, which were fine, before ordering new pump. Installed new pump, same problem. Impeller …

Fix For Aquabot Motor Not Reversing 
This series of excellent emails is from Ian who correctly diagnosed and cheaply repaired his Aquabot motor. Way to go Ian and thanks for this excellent …

My Aquabot does not clean the entire pool 
I purchased my aquabot turbo 2 months ago. At first it couldn't climb the walls and I fitted on the brushes the climbing rings. Then the timer gave up …

has anyone opened up the T2 motor assemble 
I have a T2 with a bad drive motor (the round one). it looks like the the top of each cylinder should screw off like a jar lid, the outer edge is even …

Aquabot Turbo T2 Power supply 
I was gifted an aquabot turbo T2 its missing the power supply. it looks like I could just use a 110 - 35 volt 5 Amp transformer to power the bot. Do …

Need Aquabot Basic/Turbo Motor 
I have 2 Aquabots, They both were used when I bought them at auctions. The first one had the short electric wire and the pool I had at that time was 12ft …

Aquabot will not reverse direction 
I've had my Aquabot classic about 3 years and as of about a week ago it will only go in one direction. The aquabot climbs the side of the pool, reverses …

Motor wire 
When opening up my motor to change the small gear that was broken I pulled one of the wires off the motor. There are two green wires from the bottom of …

How much oil fills the Aquabot motor? 
I have opened the drive motor because of electrical problems. I have changed the 4 diodes and everything is working. The problem that I have is that I …

Drive Motor for Admin. reply 
My last story was that one of the green wires came off the drive motor. It is a one motor original aquabot. Two wires from the bottom of the drive motor …

Aquabot Drive Motor Repair and Oil 
I opened up my drive motor and saw that the gear was worn out. So I changed the gear with another one from another aquabot. W hen putting back the motor …

Aquabot Repair, Drive Belts Slipping, Won't Climb the Walls 
This is a series of Emails about a broken robot and subsequent repair. Hi. Thanks for your reply. Actually, the bot isn't moving. It is hard to describe …

Aquabot Only Appears to Go in One Direction/Not for Long 
My Aquabot will work when it is first turned on, but it appears to only go in one direction. Also, it runs for about 45 - 60 minutes then shuts down (I …

Not moving, Pump works. 
My aquabot is 4-5 years old. I take good care of it and talk to it nicely but it has stopped moving. Suction is great but it won't budge. The gear strap …

Aquabot Broken - will not start 
My Aquabot Turbo started to stop frequently. If I pull it under water with my hand, it will momentarily start and when I let it go, it will stop. Both …

Around and Around 
My aquabot works perfectly except for one little thing. Some thing is wrong with the driving system. The pump, motor, and everything else works. But when …

Drive motor failed 
It stopped moving. Upon investigation it appeared that the motor was spinning but the main gear had broken away from the drive shaft, and did not spin …

Robot Always Eats The Power Cord 
There has to be some type of solution to the problem I have with my Aquabot. It is constantly swallowing the power cord, to the point that I have to sit …

Motor Screws 
Please don't remove the four philips head screws. They release the oil inside the motor (into the Aquabot). Instead remove the four screws off the blue …

Aquabot T4 won't reverse... 
Hello Everyone, We have an older version T4 that will not reverse directions. Belts have been replaced, and it goes very well in one direction, but will …

Click here to write your own.

Help me fix my Aquabot 
I need help! I have a Aquabot basic unit and it stopped working after 15 years. I took it to a repair place, not an authorized dealer and he said it might …

aquabot turbo classic drive motor Broken 
bought my pool cleaner 5/2014 used it for 2 1/2 mos. then 2015 3 mos and brought to Island recreation authorized repair ct.. however they were closed …

Aquabot Classic Capacitor Replacement Not rated yet
Aquabot classic dead in water. Take Aquabot apart. When separating pump from drive, noticed wire from pump was blown away from terminal on drive motor. …

Aquabot only runs for 5 mins and then turns off. Not rated yet
I have had the aquabot fury for about 6 years. It started to only run for 5 mins and then turn off. Any ideas? I saw something about a timer but I don't …

Aquabot Hornet motor works but won't move Not rated yet
I've had the 'Hornet' for a few years...it has been great...last year it stopped rolling. There are no belts or anything....very simple design...the water …

Ripped off by aqua products. Not rated yet
I bought an aqua bot jounior from Harrows on 7/14 14.On 9/14 15 it died.Two moths over warranty.It cost me 400.00 and should have lasted more than 1 season.Harrows …

Power Supply difference between two prong and three prong Not rated yet
My Turbo T-Jet motor died yesterday. I google ebay to find another Turbo T-Jet and find an aquabot Ecojet without power supply. My old Turbo T-Jet has …

T -Jet not reversing Not rated yet
I have a Turbo T-Jet and I just replaced the motor and went to try it out and it goes one direction and cleans well but when the power supply clicks to …

AquaClean sucking from top and blowing from the bottom? Not rated yet
So my bot appears to suck from the top downwards, and blows out through the bottom, so hard in fact it dislodges the clips that hold the tray/filter bag …

Aquabot JR pump problems. Not rated yet
Aquabot moves and pump runs for about minute or two when I turn system on. Then pump stops but unit continues to move for 10-20 minutes before pump starts …

Aquabot - tale of failing parts woes... Not rated yet
I have a basic model Aquabot. It was making a hard task of climbing the pool walls recently, so I replaced the drive belts and tracks myself. This didn't …

Belt repair blues Not rated yet
I have a Pool Demon, which according to AquaBot is a relabeled Classic. I have many years experience in back yard auto repair, encompassing many tasks …

stopped while running in the pool Not rated yet
After stopping in the pool, I took the Aquabot out, tried it outside the pool, and it ran. I put back in and it never started. Tried it once again, outside …

pump  Not rated yet
Turbo T Pump motor works for less than 1 min. ..then stops...replaced motor same issue. Will run out of pool. Please help ADMIN REPLY: Could be the …

Turbo T-Jet Motor and now maybe cord? Not rated yet
So last summer my wife pulled our Turbo T-Jet out of the water without turning the power off. I didn't discover this until about a week later (thankfully …

Wet Aquabot Transformer Not rated yet
Recently, i accidentally left my aquabot transmitter box under an umbrella in the rain but not turned on. It doesnt power up anymore. Is it shot or is …

aquabot pool demon Not rated yet
The unit moves in the water, but it is not blowing water out of the top jet thus preventing it from staying down. Any information is appreciated. ADMIN …

T4 doing 360s Not rated yet
I have a IntheSwim branded version of T4 with two drive motors. Unit will work fine until in tries to change direction then it just spins in place in circles …

Bravo stops after running for a min or 2 Not rated yet
My Aquabot Bravo stops running after a short time is there a way to fix it or bypass the timer? ADMIN REPLY: Most certainly theres a problem with the …

Aquabot classic needs help Not rated yet
I have an aquabot classic that is about 3 years old. It still vacuums, changes direction, climbs the walls but it will just get stuck it seems in a stationary …

Belt and brushes need to change Not rated yet
Hi guys, My Aqubot bravo +'s pump is working very well but it can't move. So authorised service checked the bot and they said that i have to change …

Easy Way to Repair Bravo/Viva Wheel Not rated yet
I found an easy way to repair the AS38237BL-AF - WHEEL TUBE ASSY for Bravo and Viva. HEX Price approx: $75.00. The drive side pin holder in the tube (pin …

aquabot t4 blows fuse after a few mins of running Not rated yet
I have an Aquabot T4 that will blow the fuse after running for a few mins. I have tried to find a broken wire in the cable, but couldn't find the smoking …

Aquabot circuit board dead Not rated yet
I get power at motor end of power cable ie good power supply. It seems that the board inside went bad anyone have a diagram of this board or know I may …

Transformer not working Model 220115C Not rated yet
I put a new fuse in and unpluged the robot. Fuse still blew. What now? Thanks for your help! ADMIN REPLY: Now you troubleshoot the power supply. …

Click here to write your own.

My Classice Aquabot Terminal Box???? Not rated yet
I'm pretty handy. So I ordered a replacement cord to replace cord that rat's severed this past winter only a few feet from 'bot. My terminal "box" is nothing …

T4 RC Nothing but problems Not rated yet
Newest problem with the T4 RC that we have is that it is blowing through fuses. I can start it up with no cord plugged in and it will stay on and hold …

T2 Runs 3 Seconds and Stops Not rated yet
My T2 starts, runs for 3 seconds and shuts down. Anybody had this experience? It's only about A year old. THANKS TO ALL!

No Motor Delivery To Pool Company Not rated yet
I have an Aquabot Xtreme and it stopped moving but will pump water. The drive motor is bad. I took it to our local pool supply, Brads Pool in Warrior,AL …

Aquabot Turbo Motor intermittent, Working Pump Not rated yet
I have an aquabot turbo like three years old used it for 3 months it stopped working due to family problems forgot about till now took it out of the …

I have a short. Every time I plug in aquabot it blows a fuse on power box.  Not rated yet
I opened the unit removed the wire cover and grey putty and found broken wires causing short. Problem is I don't know what the correct wiring is to attach …

Inherited litttle boy Aquabot Not rated yet
My wife and I bought this house at the end of 2010. In the agreement, we kept the aquabot, because I had never owned a pool and I liked things that did …

Aquqbot turbo blows fuses. Not rated yet
Aquabot Turbo blows fuses when robot is attached , does not when cable is removed. . My female three prong cable plug looked worn so I cut it off. Where …

Aquabot Express Blows Fuse Not rated yet
Need help please. My Aquabot Express blows the fuse when I submerge the unit just enough to pump (vacuum) water. I checked the transformer without …

Old T4 Wired Remote Unit Not rated yet
Cant find wired remote. Is there a fix or does anyone know which wires do what? ADMIN REPLY: I refer these tough questions to Aquaquality Pools and Spas, …

circuit board Not rated yet
my kk turbo master drive has a bad curcuit board need to replace board where can i get a replacement board? kk ADMIN REPLY:From a used motor

Turbo T2  Not rated yet
My turbo T2 pool cleaner the main blue belt keep coming off the track ? ADMIN REPLY:You need new tracks. they stretch over time

Took Motor Apart, Spilled the Oil Not rated yet
I thought I would take the motor out to see if it had clogged and when I did oil ran out all over the yard, good thing it wasn't near the pool. I call …

My Bravo is sucking in water from the top vs the bottom Not rated yet
Hello, I have an Aquabot Bravo (2005). The pump just started working in reverse. It is sucking water from the top vs pushing it out. The drive motor …

aquabot turbo reversing issues Not rated yet
My aquabot turbo will start fine run in one direction then reverse and run in that direction and then wont switch directions anymore it just stays in that …

Propellor turns wrong way? Not rated yet
My Aquabot T2 starts fine but within a few minutes starts to tip backwards even on the pool floor. I noticed that when this happens the propellor s rotating …

Aquabot T4 lost at Aquatic Distributors Not rated yet
I sent my Aquabot T4 to Aquatic Distributors in NJ because the machine would not change direction. That was almost 3 months ago and they cannot fix the …

Aquabot Turbo won't reverse Not rated yet
Has anyone successfully diagnosed a circuit board problem on an Aquabot Turbo? The motor on mine drives fine, but only in one direction. It seems a little …

Aquabot Xtreme Propeller Not rated yet
had my aquabot for 3 years now. No problems until this morning all three blades from the propeller broke off. Trying to find just the propeller. Anyone …

Wired remote for Aquabot Turbo Not rated yet
I have an older Aquabot Turbo with a wired remote control unit that allows the user to steer the bot to the left or right. The remote plugs into the power …

Broken Aquabot Cable Wire in Texas Not rated yet
I have a Aquabot Turbo, on it's fourth season. The unit began intermittently shutting off completely. I tested the continuity and determined it was not …

Aquabot box Not rated yet
So my aquabot is about 5 years old. This year the aquabot stopped climbing and reversing, got it checked out and it worked fine with another box. When …

Aquabot 60T motor loose wires Not rated yet
i have a black wire and a white wire cominig out of a 60t motor, and a brown wire and white wire coming from the drive gear how do i attach these 4 wires …

Aquabot works maybe five or ten minutes and shuts off Not rated yet
My Aquabot works maybe five or ten minutes and shuts off. I hit the reset button and it starts working again but continues to stop after a few minutes. …

Drive axle on Aquabot motor Not rated yet
Hey There, Aquabot stopped motoring around the pool on me. I took apart with the help of this GREAT website. It seems the pin on the axle motor drive …

Click here to write your own.

Aquabot Cord Plug Replacement With Computer Cable Not rated yet
The cord plug on my Aquabot power supply broke with years of use. I about panicked and realized the plug is exactly like the plug on computers. I had an …

Aquabot power supply blows fuse Not rated yet
Aquabot power supply kept blowing fuse. (I was using 2 amp fuse, looked like original) I checked voltage out of supply, was ok, but voltage at motor …

no power  Not rated yet
Hi, i have an Aqua products .Yesterday ,when i cleaned my pool everything working fine until 3 hours later the Aqua cleaner shut off (earlier than usual).i …

aquabot viva pro doesnt turn on (only 2 lights) Not rated yet
hi, couple of weeks ago bought a viva pro aquabot. It really is helping to clean the pool professionally. Today tried to switch it on, and only the …

Aquabot Bravo faster than Turbo Not rated yet
I used to own an aquabot turbo and replaced it with an aquabot bravo. It is really fast and cleans the entire pool. But the problem is when there is dust …

Aquabot Classic Stops Moving Not rated yet
Aquabot classic, 2 months old. During a cleaning cycle, the unit will stop moving, the drive belts are not turning and the water pump is pumping water. …

is the aquabot turbos made for round above ground pools or just square?  Not rated yet
I got an Aquabot Turbo for a gift for my round above ground pool.. its used. But works great but when it tries to climb the walls it just flips over? …

aquabot not moving. Not rated yet
I am very mechanically inclined and know electronics too. I have alrady taken apart the drive motor and it looks good. I took motor out of gear box and …

250 volts fed to 110v Aquabot T4 malfunction Not rated yet
Hello, I stupidly connected a 12 month old Aquabot T4 to a 250 volts AC supply not the 110v supply which it is designed to operate on. After replacing …

Aquabot won't reverse direction Not rated yet
Aquabot Turbo goes one direction, stops when the timer tells it to, then starts back up in the same direction. My timer is a 0 to 60 second timer. I hooked …

aquabot only goes in one direction Not rated yet
Just bought a house with inground pool. It has an Aquabot, hooked it up but it only turns one way noticed only one wheel track moving is this an easy …

moves during 5 mn and stops Not rated yet
i have a turbo elite. It runs correctly during 5 min and stops. I checked the power after unplugging the robot, and i have power. I have to wait about …

Quality of "replacement parts" Not rated yet
I have an Aquabot Turbo for going on three years This site was WONDERFUL in helping on all aspects of general maintenance for I am mechanically disinclined …

My aquabot turbo Nessie is slow Not rated yet
My aquabot moves very slowly or stops. Upon examination, one belt does not have tension. I put in new belts but it reacts the same, one belt making a …

freddie that 's his name(He is getting slow)  Not rated yet
we love freddie, BUT he is moving slow and has trouble climbing the walls and is getting stuck. i know the difference between a flat head and a phillips. …

Click here to write your own.


Back to Aquabot Repair